Resolved
Degraded
Payments
3DS challenge latency
Started Aug 28, 2026 16:02 UTC
3-D Secure challenges took longer than usual.
Timeline
-
Investigating · Aug 28, 2026 16:02 UTC
Customers are waiting longer on the 3DS step.
-
Resolved · Aug 28, 2026 23:51 UTC
Challenge time is back to normal.