Resolved
Degraded
Maps
Maps provider latency
Started Jul 8, 2026 15:51 UTC
Geocoding succeeded but was slower than our SLO.
Timeline
-
Investigating · Jul 8, 2026 15:51 UTC
Map lookups are slow. Autocomplete is usable but delayed.
-
Resolved · Jul 8, 2026 23:40 UTC
Maps latency is back within our normal range.