Resolved
Down
Maps
Autocomplete unavailable
Started Aug 9, 2026 09:15 UTC
Address autocomplete returned errors until we failed over the maps key.
Timeline
-
Investigating · Aug 9, 2026 09:15 UTC
Autocomplete is erroring for new searches.
-
Resolved · Aug 9, 2026 13:37 UTC
Traffic is on the backup key. Autocomplete works.