Resolved
Degraded
Email
Email provider delay
Started Sep 3, 2026 17:28 UTC
A smaller delay at the email provider slowed some transactional messages.
Timeline
-
Investigating · Sep 3, 2026 17:28 UTC
Some notification emails are arriving several minutes late.
-
Resolved · Sep 4, 2026 01:17 UTC
Email inject time has recovered.