Resolved
Down
API
API timeout burst
Started Jul 29, 2026 08:42 UTC
A subset of API requests timed out until we rolled back a deploy.
Timeline
-
Investigating · Jul 29, 2026 08:42 UTC
Timeouts are spiking on several endpoints.
-
Identified · Jul 29, 2026 10:13 UTC
A deploy introduced a blocking call. We are rolling it back.
-
Resolved · Jul 29, 2026 13:04 UTC
Rollback is complete. Timeouts have returned to normal.